記事一覧

警告「同じ依存アセンブリの異なるバージョン間で競合が見つかりました。」が表示される。 | Xamarin.forms


以下の警告が出力されるケースが存在します。

「同じ依存アセンブリの異なるバージョン間で競合が見つかりました。Visual Studio では、この警告をダブルクリックする (または選択して Enter キーを押す) ことで、この競合を修正できます。または、アプリケーション構成ファイル内の "runtime" ノードに、次のバインド リダイレクトを追加します:
<assemblybinding xmlns="urn:schemas-microsoft-com:asm.v1">
<dependentassembly>
<assemblyidentity name="System.Runtime" culture="neutral" publickeytoken="・・・">
・・・
</assemblyidentity>
</dependentassembly>
</assemblybinding>



前提条件
・Windows10
・Visual Studio 2015 Community Update3
・Xamarin 4.2 (4.2.0.695も)


ダブルクリックしても、Androidプロジェクト内のapp.configに追加されません。
さらには手動でapp.configのdependentAssemblyに追加しても警告は出続けます。

Xamarin.forms 4.1.2.18 以下のバージョンでは発生しません。


別件(iPhoneSimulatorの一覧に有効なデバイスが表示されない不具合)でXamarin4.2.0.695にしなければならず、対応に困ります。

なんとかしてください、Microsoftさん。Xamarinの大量のエラーに困っています。

2016/12/03追記
Xamarin のバージョンを 4.2.1.64 以降にすると警告が出力されなくなりました。
しかしながら、iOSシミュレータが使用できなくなるなどの不具合がありますので、慎重に対応してみてください。



当ブログの内容をまとめた Xamarin逆引きメニュー は以下のURLからご覧になれます。
http://itblogdsi.blog.fc2.com/blog-entry-81.html


関連記事

コメント

コメントの投稿

アルバム

広告

プロフィール

石河 純


著者名 :石河 純
自己紹介:素人上がりのIT技術者。趣味は卓球・車・ボウリング

IT関連の知識はざっくりとこんな感じです。
【OS関連】
WindowsServer: 2012/2008R2/2003/2000/NT4
Windows: 10/8/7/XP/2000/me/NT4/98
Linux: CentOS RedHatLinux9
Mac: macOS Sierra 10.12 / OSX Lion 10.7.5 / OSX Snow Leopard 10.6.8
【言語・データベース】
VB.net ASP.NET C#.net Java VBA
Xamarin.Forms
Oracle10g SQLServer2008R2 SQLAnywhere8/11/16
ActiveReport CrystalReport ReportNet(IBM)
【ネットワーク関連】
CCNP シスコ技術者認定
Cisco Catalyst シリーズ
Yamaha RTXシリーズ
FireWall関連
【WEB関連】
SEO SEM CSS IIS6/7 apache2

休みの日は卓球をやっています。
現在、卓球用品通販ショップは休業中です。